Android 5.1 Gapps for Custom ROMs!

android5.1-lollipop-gapps-for-custom-roms

*Note – This is a public announcement for custom ROM flasholics and people super “HIGH” on Android.

For those of you already installing custom ROMs on Nexus devices (like I’ve been doing with my Nexus 6 for the last few days), make sure you use Android 5.1 Gapps as older Android 5.0.1/5.0.2 Gapps are not compatible.  If you do install older Gapps, you will get a force-close error at the end of phone setup, which makes your phone useless.  I just want to warn you guys since this happened to me while installing a new Android 5.1 custom ROM on my Nexus 6.

The following Gapps is also minimal(only 88MB) which is great news for those of you installing Android 5.1 on older Android devices (where you may get sufficient storage space error with regular Gapps) and install minimal set of Google apps like the Play Store.   If you want more Google apps, you can always install them through the Play Store afterwards.  Besides that, I know some of you detest bloatware so definitely these Gapps should give you just the minimal apps without any Google apps you don’t want.

Also, you DO NOT NEED Gapps for Samsung TouchWiz-based ROMs or HTC Sense-based ROMs.   Gapps are only used for AOSP ROMs (What is AOSP?) on Samsung/HTC devices.  FYI, all Nexus devices use AOSP ROMs and newer Motorola devices like the Moto X also use AOSP ROMs by default (Motorola ROMs are slightly modified-versions of AOSP).

Confused?

Don’t worry, if you don’t get what this post is about follow this short guide:

Step 1. Install your new Android 5.1 Lollipop ROM.

Step 2. If missing Play Store, download the Android 5.1 Lollipop Gapps and install with CWM or TWRP recovery (installation is same as ROM without any wipes).

Join the HighOnAndroid VIP Fans List for free help from Max and discounts on Android accessories.

Max Lee

Max Lee is the founder of HighOnAndroid.com. Max makes Android tutorials and review videos for people who want to get high on Android over at his YouTube channel and Korean YouTube channel.

4 Responses

  1. terry snell says:

    max I have a Verizon HTC m8 I wondered if you can tell me how to get 5.10 lollipop firmware I tried hboot and it fails I am rooted unlocked S OFF maybe wrong firmware but I have research and supposedly is correct I know you can use ADB fastboot but I need to know for sure that I have the right before I tried this any help or advice you can give me would be appreciated

  2. Alex says:

    hi..huge fan of your youtube channel…i was just wondering if the 5.0.2 gapps package would be compatible with the 5.1.0 update…i use cm12 on my t-mobile s4 and since the cm12.1 nightlies are out and cyanogenmod promises that the updates are safe to be flashed over the existing cm12…do i need to flash another install package? if so can you please provide a link for me?

  3. Sameer says:

    Hey Max,

    So here’s what happened. I wanted to install full stock 5.1 gapps when updating to cm12.1 because I use all gapps and thought this would be the best solution. I got a status 6 error due to not having a compatible recovery (I am on 6.0.4.7), so I used these minimal gapps instead. Unfortunately, I cannot use my phone as I am getting errors such as Unfortunately (Messenger, Google Play Newsstand, Hangouts, Youtube, Gmail, Keep, etc.) has stopped working. I am stuck and cannot upgrade my recovery without access to my phone because my phone isn’t recognized in fastboot for some reason. I am using a Samsung Galaxy s4 SGH-M919. Any help would be great, thanks!